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Abstract—Network-oriented intelligent lighting system 
integrated circuit automation design, in accordance with the 
integrated circuit multi-layer grid, the shortest path wiring 
structure, the use of Cadence or PSPICE and other EDA 
(Electronic Design Automation) simulation software, to carry 
out the digital circuit, analog circuit partition component design, 
the reasonable setup of bipolar (triple-pole) tube, Resistor, 
capacitor, inductor location and system parameters, automated 
scanning and analysis of DC or AC circuit transient current, 
voltage, signal frequency, based on the bias circuit schematic 
diagram to make a polyharmony oscillator circuit logic design 
structure, analog operating temperature rules check and 
verification, in order to ensure that the integrated circuit 
emitter, base current or voltage and other parameters in line 
with the needs of semiconductor design, enhance the Internet of 
Things intelligent lighting system Overall performance and 
working safety of IoT intelligent lighting system. 

Keywords—Electronic Design Automation (EDA) simulation 
techniques, integrated circuits, design, applications 

I. INTRODUCTION

Today’s Io intelligent lighting system involves a variety of 
environmental sensors, command controllers and other end 
devices within the system, the introduction of Computer 
Aided Design (CAD), PSPICE, Mentor PADS or Cadence 
and other electronic automation simulation and design 
software, to provide support for the design of the intelligent 
lighting system for the digital circuitry, analog circuitry 
component wiring design. It can realize the reasonable layout 
of IC components under different application scenarios. 
According to the conductivity of different components 
connected in the integrated circuit of the intelligent lighting 
system, as well as the noise of the data sampling of capacitive 
and inductive signals, the accuracy and completeness of the 
circuit signals are verified by using the HSPICE software, 
which can ensure that the command response of the system 
design and the PWM dimming curves can meet the service 
requirements of intelligent lighting [1]. 

II. FUNCTIONAL CONTROL CIRCUITS, INTEGRATED CIRCUIT

STRUCTURE ANALYSIS OF THE INTERNET OF THINGS 

INTELLIGENT LIGHTING SYSTEM 

A. Function Control Circuit Design in Intelligent Lighting
System

The current indoor intelligent lighting system is mainly 
oriented to the control needs of light brightness and 
extinction, light intensity, color temperature and other 
adjustments, set up to cover the microprocessor unit, ambient 
light sensors, temperature sensors, LED drivers, 
photoresistors, power management units, storage units, the 

composition of the circuit structure [2]. Which selected ARM 
RTL8019AS 32-bit microcontroller, Vishay TEMT6000 
photosensitive sensor, TI TMP117 temperature sensor, 
Infineon ILD6070 LED driver, as well as TCP/IP stack, 
CSMA/CD protocol, Zigbee/BLE protocol, ESP8266 
interface and other communication Technology to construct 
the system functional circuit, forming the LED lamp remote 
PWM dimming, temperature control light regulation control. 

ARM RTL8019AS main controller peripheral set AC-DC 
power supply interface, 3.3~5V output voltage, to provide 
DC / AC circuit power supply management; set ADC pin for 
the environment sensor collection of analog signals to 
provide support for the incoming, set GPIO pins, CSMA/CD 
protocol to meet the needs of the local area network within 
the control of the LED driver and connectivity requirements, 
set the I ² C / SPI Set up I²C/SPI bus, I/O pin interface and 
other connection ports to provide support for digital signal 
conversion, PWM dimming signal output control [3]. 

And then based on the UART interface, TXD/RXD pins to 
form a microcontroller and access to the serial 
communication of the lighting module, according to the 
system load, driver specifications to connect the LED string. 
Using the power manager +5V, rated current of 200μA 
half-duplex communication mode, the driver through the 
TXD/RXD terminal, digital to analog signal converter 
through the AD port and the microcontroller microprocessor 
connected to the analog-to-digital converted signals are 
output to the ARM RTL8019AS 32-bit microcontroller to 
make processing analysis [4]. LED driver is set by the current 
sampling resistor R6, inductor L1, current diode composition 
of the self-oscillating current mode, the LED sampling 
voltage and bias voltage comparison to generate PWM 
control signals, and then by the ARM RTL8019AS main 
controller of the power switch manipulation drive circuit 
conduction and shutdown, the same kind of signal 
components are centrally laid out, and through the resistor 
grounding [5]. 

B. Integrated Circuit Structure Analysis of Intelligent
Lighting System

Intelligent lighting system integrated circuit design, the 
choice of digital circuits, analog circuits separate 
master-slave control mode, divided into light signal sampling 
circuit, A/D analog-to-digital conversion circuit and other 
components of the structure. The host is the ARM 
RTL8019AS master controller for high-frequency signal 
transceiver communication, and the slave is the MAX485 
controller (Fig. 1) [6].  
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Fig. 1. Integrated circuit structure of ARM RTL8019AS host controller. 

 
Master-slave controller is in half-duplex operating state, 

using P1.0~P2.7 pins on the analog-to-digital conversion 
after the transmission and reception of differential signal end 
of the control, and P pins connected to the A terminal and B 
terminal for sending and receiving differential signals, when 
the level of the A terminal is higher than the B terminal 
indicates that the signal is in the transmission state, the data is 
1, otherwise indicates that the signal is in the reception state, 
the data is 0, the master controller ARM RTL8019AS control 
receiver to complete the digital signal transceiver 
communication. Based on the TLP521 photocoupler 
anti-jamming support, the host receives through the 
P1.0~P2.7 pins to control the transceiver’s operating state, 
usually set P1.0 and other pins interface to a low level, so that 
the host’s serial port is in the signal receiving state, when the 
serial communication interruptions to determine the address 
of the signal, and will be set to a high level on the P1.0 pin to 
the host’s serial port is in the signal to send the answer state 
[7]. 

Fig. 1 in the A/D analog-to-digital converter 
analog-to-digital conversion is another core of the control 
circuit, the use of Texas Instruments TLC1549 
analog-to-digital converter access to the microcontroller 
system, for the high impedance input electromagnetic 
induction, electrostatic coupling noise problems, the use of 
differential reference voltage high impedance input, in the 
reference voltage source power supply side to add LC-type 
filtering circuits, will be two 100pF~1nF capacitors 
respectively Connect the differential line and ground, 
constitute a low-pass filter circuit, used to inhibit and filter 
out high-frequency signal input ripple noise interference, the 
input denoising high-frequency signals are transmitted to the 
master-slave controller, the application of the microcontroller 

circuit to control the light of the intelligent switching, 
brightness and color temperature adjustment [8]. 

III. IC DESIGN EXECUTION FLOW BASED ON EDA 

SIMULATION TECHNOLOGY 

PSPICE, Cadence or Mentor PADS and other EDA 
software electronic automation simulation design, mainly 
upholding the concept of systematic chip design, large-scale 
digital circuits, analog circuits, digital-analog hybrid 
simulation experimental design, according to the complexity 
of different integrated circuits of the functional requirements 
of the set schematic input, PR/EDIF netlist, component 
wiring, rule checking, layout extraction, parasitic parameter 
extraction, EDA simulation, etc., so that the layout of 
components in the circuit, circuit performance indicators to 
meet the actual scenarios and application requirements. 

A. IC Design Flow Based on PSPICE Simulation Software 

After the start of the PSPICE software, click the menu bar 
“File->New->Project” to create a new project, select “New 
Schematic” to open the schematic editing window, in the 
project manager click the menu bar in the project manager, 
click on the menu bar “Place->Part” to create the 
corresponding components, use the “Place -> Wire” 
command to draw the wires between the component pins. 
And then according to the drawn schematic for PR/EDIF 
netlist generation, select the menu bar of the “PSpice -> 
Create Netlist” command to generate the netlist file, the 
netlist file records the parameters of the circuit components, 
connectivity and other information to complete the schematic 
drawing centered on the needs of the intelligent lighting 
system [9]. 

After that, the netlist file will be imported into the PCB 
design module to make component wiring, in the PSPICE 
software menu bar click on “File -> “Export -> Netlist” 
command, to generate EDIF format netlist file, and then in 
the PCB design software click on “File-> Import” -> Netlist 
“import netlist, click” Place-> Component “command will be 
placed in the layout of components to the netlist area, click” 
Route-> Auto Route “to select the layout of the netlist. 
“Route->Auto Route” command for automatic routing 
operations. 

After completing the netlist wiring of different 
components, click “Tools -> ERC” command in the 
schematic editing window, the simulation software to check 
the circuit whether there is too wide a line width, 
unreasonable spacing, open/short, pin overhang, etc. If there 
is no error problem, then use Layout Extraction tool to extract 
the layout and click “Analysis -> Parasitic Extraction” 
command to extract parasitic parameter information, 
including voltage, current, resistance, capacitance, 
inductance and other parameter information. Extract the 
layout and click “Analysis -> Parasitic Extraction” command 
to extract parasitic parameter information, including voltage, 
current, resistance, capacitance, inductance and other 
parameter information. Finally, a new simulation profile is 
created in the schematic editing window, and the parameter 
ranges for AC/DC scanning, DC-AC analysis, and transient 
analysis are set to make a simulation run of the circuit to 
ensure the accuracy of the electronic automation design. 
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B. IC Design Flow Based on Cadence Simulation 
Software 

Open the software: Start the Cadence software to enter the 
main interface, click the menu bar of the “File->New->Cell 
View” to create a new project, in the process library to select 
the CSMC × nm integrated circuit process. After that, click 
the “Place->Instance->Browser” command in the menu bar, 
select the component models of resistors, capacitors, MOS 
tubes, etc., and draw the wires between the component pins 
using the “W” shortcut key in the “New Schematic” window 
of the schematic editor. Place the components, use the “W” 
shortcut key to draw the connection between the component 
pins [10]. 

And then according to the circuit schematic connection 
line for PR/EDIF netlist generation, in the schematic 
interface click on the menu bar of the 
“Tools->Simulation->Netlist->Create Netlist” command, 
selected Spectre, SPICE, EDIF, and other netlist formats to 
generate netlist files, the SPICE format netlist files exported 
to . cir files will be imported into the PCB design tools to 
make component wiring. In the schematic interface, click 
“Tools->Simulation->Netlist->Create Netlist” command in 
the menu bar, select Spectre, SPICE, EDIF and other netlist 
formats to generate the netlist file, and then export the netlist 
file in SPICE format to a .cir file, and then import the netlist 
file into PCB design tools to make the wiring of components. 
In the PCB design software menu bar click 
“Place->Manually->Quickplace” command, the use of 
manual or automatic way to place a variety of components, 
the use of “Verify-> Constraints Use the “Verify-> 
Constraints” command to set a reasonable wiring width, 
spacing. 

Finally, in the schematic editor page, click “Verify-> 
DRC” command, select the CSMC×.drc rule file with 
different integration accuracy, and check the wiring results of 
the electrical components in the schematic diagram, so that 
the wrong wiring and marking information can be found in 
time, and then make the layout extraction after all the wiring 
is accurate. After all the wiring is accurate, the layout is 
extracted. Set extraction parameters through “Tools->Layout 
Extraction” command in the menu bar, and set parasitic 
parameters through “Analysis->Parasitic Extraction” 
command in the menu bar. After setting the parasitic 
parameters through the command “Analysis->Parasitic 
Extraction” in the menu bar, the layout and parasitic 
parameters can be extracted within a specific precision and 
range. Also after the completion of the integrated circuit 
design, set the AC/DC conversion signals, circuit transients 
of the simulation type of simulation run to ensure that the 
simulation of the circuit diagram drawing, component wiring 
placement accuracy. 

IV. PSPICE SIMULATION TECHNOLOGY IN THE 

INTELLIGENT LIGHTING SYSTEM INTEGRATED CIRCUIT 

DESIGN APPLICATION PROGRAM 

A. Application of PSPICE Simulation Technology in the 
Design of Intelligent Lighting System Integrated Circuits 

Based on the menu bar “File-> New-> Project” of PSPICE 
software, create a new project of “Intelligent Lighting 
System”, place resistors, capacitors, filter capacitors, diodes 

and other components in the schematic diagram of the project, 
connect the wiring components by clicking on the command 
“Place-> Part->Wire”, set the system voltage threshold as ＋
5V~+30V, current threshold as 200μA~1A for the LED 
driver. Place resistors, capacitors, filter capacitors, diodes 
and other components in the schematic diagram of the project, 
connect the line components by clicking on the command 
“Place-> Part->Wire”, set the voltage threshold of the system 
as ＋5V~+30V, and the current threshold as 200μA~1A, to 
provide support for the hysteresis control of the current of the 
LED driver. 

Through the “Place->Manually->VPULSE” command to 
simulate the driver output PWM signal, according to the 
human eye to watch the intelligent lighting system, “visual 
retention” principle, set the LED driver to enable the 
frequency of PWM signals According to the human eye to 
watch the intelligent lighting system, “visual retention” 
principle, set the frequency of the LED driver enable PWM 
signal to 100Hz~1kHz, duty cycle of 0 ~ 100%, connected to 
the resistor, capacitor, diode opto-coupler isolation circuit, 
specific as shown in Fig. 2. As the maximum input voltage of 
the reference circuit is 30V, the integrated circuit common 
current control MOS tube withstand voltage of+5V, and thus 
add a gate-drain short between the MOS tube drain source for 
circuit protection to prevent the integrated circuit end of the 
high-voltage breakdown [10]. 

 

 
Fig. 2. Analog dimming PWM signal equivalent circuit diagram. 

 

From the analog dimming PWM signal equivalent circuit 
diagram in Fig. 2 the output of the EN signal can be 
controlled by comparing the input signal voltage at the DIM 
pin with the size of the low threshold voltage VT_L and the 
high threshold voltage VT_H. In the DIM pin voltage from 
high to low, the current flowing through the LED tube I is 
also reduced proportionally, when the DIM pin voltage is 
lower than VT_L (0.5 V) when the power tube is cut off, 
when the DIM pin voltage is low to high, the LED tube to 
make the brightness and color temperature adjustment, 
higher than the high threshold voltage VT_H to complete the 
enable conversion. 

B. Simulation Results Analysis 

Based on the CSMC 1nm IC process model, the circuit 
design results of the “Intelligent Lighting System” are 
simulated and verified using HSPICE software. In 20ms 
simulation time, set the sampling resistor RS = 0.3 Ω, 
inductor L=100μH, and run “PSpice->Run” to check the 
output current accuracy [11]. 
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Fig. 3. Simulation experiment results. 

 
The chip output current deviation is found to be 

0.5%~3.5% when driving 5 LED light sources, and the output 
signal topology of the circuit after adding the matching 
resistor is shown in Fig. 3, which shows that the terminated 
signal waveform is gradually stabilized by the oscillation, 
and the simulation results are very satisfactory and can meet 
the practical requirements. 

V. CONCLUSION 

In summary, the intelligent lighting system IC design 
based on EDA simulation technology can be achieved by 
using Cadence, PSPICE simulation software technology to 
make a reasonable wiring of the rectangular grid channel, in 
the project engineering page of Cadence Allegro to make the 
analog power supply, micro-controller, photoresistor and 
other circuit components of the alignment layout design, by 
the micro-controller to PWM digital The microcontroller 
converts the PWM digital dimming signals into current 
control signals, performs transient simulation operation 
calculations of input/output voltages and currents, and 
realizes the optimization of the whole process from 
architectural design to simulation verification. 
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